wiki:AndroidRelease

Talos Rowing Release Page

Note: you need a device running Android 1.6 or above to use Talos Rowing. Here is the latest release page.

Last modified 11 years ago Last modified on Jun 29, 2012 11:33:42 AM